当你想在你的代码中找到一个错误时,这很难;当你认为你的代码是不会有错误时,这就更难了。

在xcode 3.1.2上为iphone os 3和4开发

admin 83℃
我对iphone编程还很陌生,我有一个运行leopard和xcode 3.1.2的macbook。我想用coredata读写plist,但我在http://tapity.com/iphone-app-development/readwrite-data-on-the-iphone-property-lists-sqlite-or-core-data/上读到coredata只在iphone os 3.0上可用。现在,我正在为ios 2.2.1开发。有没有什么方法可以为ios 3.0甚至ios 4.0开发leopard,或者我需要升级到snowleopard?

谢谢!

你应该升级。只有当应用程序是根据最新的sdk构建的(即使目标操作系统是一个主要版本),苹果才会批准这些应用程序。所以,基本上,如果你打算最终将应用提交到商店,你别无选择。

不确定是否可以将最新版本的ios sdk与您安装的xcode版本一起使用,但这将是一个明显的解决方案。我相信您至少应该能够在xcode 3.1中使用3.0sdk的早期版本。

但是,我建议你无论如何升级——在最近的XCODE更新中还有很多其他有用的特性,Snow Leopard无论如何都会给你现有的硬件带来更好的性能。

转载请注明:我的代码 » 在xcode 3.1.2上为iphone os 3和4开发